SAP Knowledge Base Article - Public

3246118 - TEXT in UI Designer Cannot be Readable by User

Symptom

User is facing issue with texts in UI Designer of SAP Cloud Applications Studio (Pilot), where the Texts are not readable in Configuration Explorer window and Logon page with small icons.

Environment

 SAP Cloud Application Studio

Reproducing the Issue

  •  Go to Cloud Application Studio
  •  Open Solution YBACDEFGHJ ( Where YBACDEFGHJ represents customer specific solution name)
  •  Open any content UI file example TT, TI, QC etc.
  •  Open the Configuration Explorer window.
  •  We observed that the texts are not readable in Configuration Explorer window.

UI screen.PNG

Cause

You have configured wrong settings for the property for Override high DPI scaling behavior.

Resolution

  •  Go to your desktop
  •  Right click on the program shortcut, Properties and view  the Compatibility tab.
  •  Click on High DPI settings

Set checkboxes:

1. "Use this setting to fix scaling problems for this program instead of the one in Settings".

=>> In "Use the DPI that's set for my main display when" select "I open this program".

2. "Override high DPI scaling behavior".

=>> In "Scaling performed by" select: "System".

This fixes all small icon and text issues in the Cloud Application Studio.

Keywords

Compatibility;Font Issue;Text issue in UI designer;Unreadable. , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem

Product

SAP Cloud for Customer core applications all versions