SAP Knowledge Base Article - Public

3246139 - [Onboarding] Upon Restricting RBP Permissions related to Email Services show "No Data" on the page

Symptom

We want the users who have access to email services to have limited RBP Permissions, but when I remove the permissions from "Configure Email Framework Permissions" and "Email Framework Object Permissions", Email Services Page shows "No Data"

Environment

SAP SuccessFactors Onboarding

Cause

  • Ideally in order to view the email services, the users should be granted permissions from "Configure Email Framework Permissions" and "Email Framework Object Permissions"
  • However, if the users are given limited permissions in "Configure Email Framework Permissions" and "Email Framework Object Permissions", we have to provide Admin User Permissions

Resolution

  • For users with restricted RBP Permissions, go to Manage Permission Role > Select the necessary RBP Role
  • Search for Metadata Framework > enable "Admin Access to MDF OData API" 
  • Save

    Keywords

    Email Services, No Data, Email Status, Email Resend , KBA , LOD-SF-OBX-EML , Notifications , Problem

    Product

    SAP SuccessFactors Onboarding 2205