Symptom
A deployment with Migrate data mode was triggered in SAP Commerce Cloud Portal, and the migrate data logs show the following errors:
|
... java.lang.NoClassDefFoundError: Could not initialize class de.hybris.platform.util.Utilities |
OR
| Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.apache.log4j.LogManager ... Caused by: java.lang.ExceptionInInitializerError: Exception org.apache.logging.log4j.core.config.ConfigurationException: No name attribute provided for Logger loggerForDefaultFacetSearchStrategy [in thread "main"] ... Caused by: java.lang.ExceptionInInitializerError: Exception java.lang.NoClassDefFoundError: Could not initialize class org.apache.log4j.LogManager [in thread "main"] |
OR
|
Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.apache.log4j.LogManager at org.apache.log4j.Logger.getLogger(Logger.java:40) at de.hybris.platform.core.AbstractTenant.<clinit>(AbstractTenant.java:119) at de.hybris.platform.core.Registry.getMasterTenant(Registry.java:870) ... 6 more Caused by: java.lang.ExceptionInInitializerError: Exception org.apache.logging.log4j.core.config.ConfigurationException: No type attribute provided for component config [in thread "main"] at org.apache.logging.log4j.core.config.properties.PropertiesConfigurationBuilder.createComponent(PropertiesConfigurationBuilder.java:362) |
Read more...
Environment
SAP Commerce Cloud
Product
Keywords
commerce, cloud, ccv2, log4j, initialize, class, de.hybris.platform.util.Utilities, Utilities, org.apache.log4j.LogManager, LogManager, attribute, Logger, java.lang.NoClassDefFoundError, java.lang.ExceptionInInitializerError , KBA , CEC-SCC-CLA-DEP , Deployments , Problem
About this page
This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).Search for additional results
Visit SAP Support Portal's SAP Notes and KBA Search.
SAP Knowledge Base Article - Preview