Symptom
You are trying to create an Outbound Integration with Attachment as the Format for an Integration Type at Integration Center (IC) but the integration is not retrieving the attachments files.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Integration Center;
- Click on My Integrations;
- Click on +Create;
- Click on More Integration Types and select:
- Trigger type as Scheduled;
- Source Type as SuccessFactors;
- Destination Type as SFTP;
- Format as Attachment;
- Click on Create;
- Select the Starting Entity;
- Adjust other settings and run;
More details about the steps above can be found in Integration Center Guide, in the Creating an Outbound Integration with Attachment as the Format for an Integration Type chapter (link).
Cause
There are many possible causes:
- Cause 1: You are selecting an invalid Starting Entity or mapping incorrect fields. See the example below. The PerNationalId entity contains the attachmentId field only (returns the attachment identifier) and doesn't contain any navigation to the Attachment entity so both starting entity and fields mapping are incorrect;
- Cause 2: You are trying to extract attachments of some employees that don't contain any;
- Cause 3: You are trying to extract some attachments that doesn't contain a specified file format (e.g. PNG, PDF). See the example below:
- Cause 4: You are trying to extract attachments from the EmpWorkPermit entity;
Resolution
To solve Cause 1:
The valid Starting Entities are the ones that have the Attachment Content field OR a navigation field (custom or standard) to the Attachment entity (e.g. EmpJob).
You can check the entity fields in the Odata/SFAPI dictionary.
After choosing a valid entity, inside the integration, follow the steps below:
- Open the Configure Fields tab;
- Click on Associate Content;
- Select the field:
- Attachment Content field;
- OR a navigation field to Attachment entity and then select fileContent field;
- Click on Associate Content type;
- Select the field:
- Attachment File Type field;
- OR a navigation field to Attachment entity and then select fileExtension field;
- Adjust other settings and run;
OBS.: For Entities without the fields above but with the attachmentId field, you can use this Id to find the corresponding attachment content (fileContent field) at the Attachment entity. Based on that, you should try alternative solutions such as doing more complex integrations, using more complete integrations tools, or making OData API calls directly. Please note that it's beyond product support's scope to assist with the implementation. For consulting matters, you may seek assistance in our SAP Community, reach out to your implementation partner, or to SAP Professional Services.
To solve Cause 2:
Under Advanced Filters, add the filter attachmentId as the example below (if necessary, navigate to the Attachment entity to find it):
To solve Cause 3:
Set a Default Value format for the attachments. See the example below:
Path: Destination Settings tab > calculator icon besides Calculated File Name field > three triples icon besides attachmentFieldType > More Field Options button
To solve Cause 4:
Refer to the KBA 3302786 resolution.
See Also
Keywords
not, don't, doesn't, retrieve, retrieving, return, fetch, fetching , KBA , LOD-SF-INT-INC , Integration Center , Problem
Product
Attachments
Pasted image.png |