Symptom
You want to pass the value of an Extension Field on Item level of a Sales Order to the Invoice Request but the value in the Invoice Request is empty for Sales Orders while for others the value is passed correctly.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Open Sales Order XYZ (XYZ represents the Sales Order ID).
- Navigate to the Items tab.
- Select the line item XX with the Item Type Product- consignment issue.
- The extension field Y has the value Z (Y represents the name of the extension field and Z represents the value).
- Open Sales Order ABC (ABC represents the Sales Order ID).
- Navigate to the Items tab.
- Select the line item XX with the Item Type Product - delivery-based.
- The extension field Y has the value Z (Y represents the name of the extension field and Z represents the value).
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Open the Invoice Request based on Sales Order XYZ.
- Navigate to the Items tab.
You can see that the extension field Y has no value. - Open the Invoice Request based on Sales Order ABC.
- Navigate to the Items tab.
You can see that the extension field Y has the value Z.
Cause
For items with Item Type Product- consignment issue the following Extension Scenarios do not work:
Sales Order - Item to Outbound Delivery Request - Item
Outbound Delivery Request - Line Item to Outbound Delivery - Line Item
Outbound Delivery Request - Item to Warehouse Request - Item
Outbound Delivery - Item to Invoice Requests - Item
Only the following Extension Scenarios can be used:
Sales Order - Item to Invoice Requests - Item
Invoice Requests - Item to Customer Invoice - Item
You have enabled the following Extension Scenarios for extension field Y:
Sales Order - Item to Outbound Delivery Request - Item
Sales Order - Item to Invoice Requests - Item
Outbound Delivery Request - Line Item to Outbound Delivery - Line Item
Outbound Delivery Request - Item to Warehouse Request - Item
Outbound Delivery - Item to Invoice Requests - Item
Invoice Requests - Item to Customer Invoice - Item
Therefore, no data is passed to the Outbound Delivery and hence there is no value in the Outbound Delivery Invoice Request if the Item Type is Product- consignment issue.
Since the outbound delivery has priority over the sales order, the data from outbound delivery overwrites the data from the sales order and therefore there is no value in the extension field in the Invoice either if the Item Type is Product- consignment issue.
KBA 2380268 - Extension Field Value is not Populating in Invoice Documents
Resolution
You need to create a separate Extension Field which is used for Items with the Item Type Product- consignment issue and then activate only the following Extension Scenarios:
Sales Order - Item to Invoice Requests - Item
Invoice Requests - Item to Customer Invoice - Item
See Also
2380268 - Extension Field Value is not Populating in Invoice Documents
Keywords
Extension Field; KUT; Extension Scenario; Invoice Request; Invoice; Sales Order; Item Type; Consignment; Logistics. , KBA , SRD-CRM-INV , Customer Invoicing , Problem