SAP Knowledge Base Article - Public

3246652 - Cloud for Customer Auto Sign Out Functionality

Symptom

For security reasons, users are automatically logged off the Cloud for Customer system if they have been inactive in the system for a certain period of time.

Environment

SAP Cloud for Customer

Cause

The Auto Sign Out setting is built based on the user interface framework. In order for the Auto Sign Out setting to work and be effective, an application session needs to be open in the browser so it can then work as countdown timer.

After you close the session, the counter for the Auto Sign Out functionality will not work; However at the same time, a backend session exists for the user login which then takes place and has a fixed time set to invalidate the session for one hour.

For the server-sided inactivity timeout, it is defined as absence of communication: the time between two subsequent http requests. This means that the user should perform some activity in the system, for example: click on some button, navigate between screens.

Resolution

As a Key User, you can set the auto logoff time for all users in your company at Company Settings:

  1. Go to User Menu.
  2. Select Settings.
  3. Click on Company Settings.
  4. Go to Auto Sign Out tab:
    • If you leave this option empty, inactive users will be logged off the system after 15 minutes.
    • You can choose between: 15 minutes, 30 minutes, 1 hour, 2 hours, 3 hours, 4 hours. 
    • SAP recommendation is to keep this value as 1 hour.
    • autosignout.png

                "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

  • If the browser is closed before the defined period of inactivity, the session will remain active. It is recommended to use the Sign Out option to perform the correct logoff from the Cloud for Customer system:
    1. Go to User Menu.
    2. Click on button Sign Out.
      c4c_signout.png

  • If you are using single sign-on, the Auto Sign Out time could not be respected as configured. Also, after a certain period of inactivity, a message is displayed offering to prolong the session. In this case, the Auto Sign Out is triggered due to the single sign-on token renew. Review the token time-out settings with your Identity Provider (IdP). The IdP threshold timeout setting should be higher as in the Cloud for Customer system. 

  • This setting will not work for Cloud for the Customer Extended App (C4C mobile application). The mobile application will time out in 60 minutes if kept idle.
  • If user is assigned to multiple business roles, please maintain the same time to sign out for all business roles.

See Also

Keywords

auto logoff, Auto Sign Out, company settings , KBA , AP-RC-UIF , C4C UI Framework , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions