Symptom
The system does not erase the previous value for some fields in job information when Legal Entity changes through job history > edit option (pencil option).
Environment
SAP SuccessFactors Employee Central - Job Information
Reproducing the Issue
- Log in the Instance;
- Go to the employee profile > Job Information;
- Go to Edit (in the pencil option) and select a random date effect;
- Change the value for Legal Entity;
- Waiting for some seconds and you will be able to see that other fields, as Business Unit, did not erase the previous value although they are not related to the new Legal Entity.
Cause
It is a known issue. The engineer team are working for a permanent fix. As soon as there are news on it this article will be updated.
Resolution
As a workaround you can change it through 'Change History' (clock option):
- Log in the Instance;
- Go to the employee profile > Job Information;
- Click on change history (clock option) and select a random date effect;
- In Job Information, change the Legal Entity;
- Waiting for some seconds and you will be able to see that other fields, as Business Unit, erased the previous value.
You can contact your CSM to follow the internal updates (ECT-132388).
Please note: this workaround will not apply for Job Information to Position Sync. If your system has this sync, you should use the "Take Action" to perform position changes.
The sync will never occur for changes made via Job History. Please refer to the KBA 2413652 - Position Management: Job Information to Position Sync Troubleshooting Guide for further information.
Keywords
ECT-205801, different behavior, job history, legal entity, change history, system erased, erase, erased, b2205, KI2311, ECT-132388 , KBA , LOD-SF-EC-JOB , Job Information , Product Enhancement