SAP Knowledge Base Article - Public

3246883 - Grid Portlet: Contact Information: Emergency Contact and Address Information portlets insertion order - Employee Central

Symptom

Primary Emergency Contact and Address Information portlets are not respecting the insertion order when adding more than one record.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors Employee Profile
  • Emergency Contact Details
  • Personal Information
  • Address Information

Cause

  • Display order in UI follows the created date and time of the records;
  • If more than one record are created together, the created date and time will be exactly the same for all three records. In this case, the display order can’t be guaranteed – sometimes following the order, sometimes not, because of implicit system process.

Resolution

Configuration Steps:

  • In case the records need to be displayed in a fixed order, the solution is to create only one record each time, so the created time will be different and reliable for ordering.

This behavior has been identified as expected.

See Also

2844049 - Formatted Address visibility in Address section of Dependents and Primary Emergency Contact portlets 

2752661 - Error When Updating Primary Emergency Contact 

2315276 - Employee Central - Data Imports Useful Information

Keywords

order, insert, insertion, Emergency Contact Details, Primary Emergency Contact, Contact Information, Address Information, Employee Central, Employee Profile , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-EC-PER-ECO , Emergency Contact Details , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions