Symptom
When Admin tries to submit e-verify the following error appears:
"E-verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access the instance as Hiring Manager/Assignee
- Click on "Complete E-Verify" Home Page Tile
- Locate Candidate and click "Start"
- Select radio button for "Yes, this photo matches"
- Click "Submit Case"
- Error message received
- Try to submit once again, before clicking on "Submit Case" button press F12 to open the Developer Tools page
- Then click on "Submit Case" button
- Under Network tab select $batch event
- In Response you are going to see the following:
Checking under the logs for this issue, please, check below: {"error":{"code":"InternalError","message":"EV_INCORRECT_STATE: The case is incorrect state","details":[{"code":"COE0019","message":"EV_INCORRECT_STATE: The case is incorrect state"},{"code":"COE0019","message":"CASE_STATUS_CONFLICT: Case is not in the correct state for this operation."}]}}
Cause
- There was an issue on the sync of SuccessFactors and E-Verify data
- The issue happens because DHS e-verify web service is not stable and the submit sometimes fails which results into "case is in incorrect state" error and it doesn’t allow user to submit the case again.
Resolution
- Engineering Team have identified the issue and a code fix is scheduled to be patched on the 21st of September.
- This will avoid such scenarios in the future.
See Also
Keywords
KBA , LOD-SF-OBX-EVF , Everify , Known Error
Product
SAP SuccessFactors Onboarding 2205