SAP Knowledge Base Article - Public

3247739 - Wrong Sequence of IDs for 3PL Requests And Other Logistics Documents

Symptom

  • For 3PL Requests, you get an unexpected sequence for the IDs generated by the system, which is not consecutive.
  • You could observe the same behavior for other logistics documents as well.

Environment

SAP Business ByDesign.

Reproducing the Issue

  1. Go to Third-Party Logistics work center. 
  2. Select 3PL Requests view. 
  3. Execute the query. 
  4. Order by Creation Date. 

Notice that the system generates the 3PL Request IDs not in sequence, as an example ID 2 is generated first and then the system created the ID 1.

Cause

  • The documents which are legally required to follow a strict sequence in their Document ID will follow them, such as Invoices.
  • For these documents where the IDs have to follow a sequence, the buffering is disabled. However, this has an adverse impact on the performance, hence for all the other objects have buffer setting maintained.
  • Other documents like Warehouse Order, request, Delivery Proposals, Tasks, have document numbers which are assigned from a cache of sequence for each of the documents and the number from this cache might skip occasionally when there are any connection errors or interruptions.

Documents for which you have the option to set up number range sequence could also experience the above behaviour.

  • The number range object used for the documents like Inbound Delivery, Outbound Delivery and other similar documents in the system uses the memory buffer.
  • When the system buffers a number range object, it does not update numbers individually in the database but reserves a present group of numbers (depending on the number range object) in the database the first time a number is requested.
  • The system makes these numbers available to the application server in question. These numbers can then be taken directly from the application server buffer.
  • New numbers are not used in the database until the application server buffer has been used up.
  • As there are more than one application servers available, the numerical sequence will not reflect the (chronological) insert sequence because the numbers are buffered separately on the individual hosts.
  • The above  definition could potentially to the following symptoms:
    • Gaps (jumps) occur when allocating internal numbers
    • The number assignment does not reflect the insert sequence.

Resolution

  • Any document which is legally required to follow a strict sequence as per the local governmental authority those documents will be following the sequence.
  • The explanation is valid for documents those are not required to legally follow strict sequence. 
  • They follow the number range buffer setting which is a central configuration and this behaviour cannot be changed.

See Also

 1914346 - ID of Documents are Created Out of Order or there are Gaps in Document IDs

Keywords

3PL, order, TPOP, number range not in sequence, Inbound delivery number range not in sequence, sequence not followed in document id, document ID not in order, document numbering issue, document number not in order, , KBA , 3pl , tpop , order , AP-SLP , Site Logistics Processing , How To

Product

SAP Business ByDesign all versions