Symptom
We are receiving the below error message in Business Process Tile when trying to complete DocuSign Signature:
“DocuSign user login failed: PARTNER_AUTHENTICATION_FAILED - The specified Integrator Key was not found or is disabled.”
Environment
SAP SuccessFactors Onboarding
Cause
- The error is caused because OAuth 2.0 which is required for all DocuSign API applications is not completed yet
Resolution
- DocuSign is deprecating legacy basic authentication. Existing customers using DocuSign need to switch to JWT Grant authentication.
- Kindly refer to the below link to complete the OAuth 2.0 JWT Grant Authentication to activate DocuSign:
https://help.sap.com/docs/SAP_SUCCESSFACTORS_ONBOARDING/c94ed5fcb5fe4e0281f396556743812c/d55d2fc4f16e4d749082cc141d400b49.html?locale=en-US&q=DocuSign%20OAuth%202.0
See Also
- For SAP SuccessFactors Onboarding 2.0:
https://community.successfactors.com/t5/Onboarding-Resources/DocuSign-Integration-Using-OAuth-2-0-Starting-First-Half-2022/ba-p/284019 - OAuth 2.0 requirements and migration - DocuSign:
https://launchpad.support.sap.com/#/notes/3115278
Keywords
DocuSign user login failed: PARTNER_AUTHENTICATION_FAILED - The specified Integrator Key was not found or is disabled, DocuSign Signature, DocuSign Failed, DocuSign, PARTNER_AUTHENTICATION_FAILED, OAuth 2.0 , KBA , LOD-SF-OBX-DSN , Docusign Integration , XX-PART-DSN , SAP Signature Management by DocuSign , Problem
Product
SAP SuccessFactors Onboarding 2205