Symptom
- While processing tickets, the Rich Text Editor is not loaded for Portal Messages within tickets
- Users are not able to edit the formatting of the text (change font/colors/..) as well as insert inline images for portal messages.
- The administrator has already enabled the UI configuration "Enable inline images for ticket description, work description, portal messages and internal memo", but the issue still exists
- The editor is available for e-mails and SMS
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Go to Services -> Ticket
- Open a ticket and go to "Interactions"
- Click New, and select "Portal"
Cause
- Missing configurations
- Business Option BO_COD_MEMO_ACTV_PORTAL (Service Portal Integration Interface) is not enabled
- The BO BO_COD_MEMO_ACTV_PORTAL is related to question "Do you want to extend your service scenarios to include an external service portal?"
- You are using the Employee tickets scenario
Resolution
- Please note the HTML/RichText Editor is not available with the Employee Support ticket scenario relating to the Portal Messages integration
- Only simple text will be used
- No inline images added to the data
- No formatting can be performed to the data
- If you are using the Customer Care scenario, then make sure that you also activate the below scoping questions to enable the Portal Response option in the Timeline view
- Go to Business Configuration Work center
- Select Implementation Projects view
- Select First Implementation -> Edit Project Scope
- Forward to Questions option
- Go to Service -> Customer Care
- Select Communication for customer care -> Service Portal integration
- Enable the scoping question "Do you want to extend your service scenarios to include an external service portal? Please note, once selected not reversible "
- Now Go to Sales->Accounts and Activity Management -> Activity Management
- Enable the scoping question "Do you want to record memo activity?"
- Review and Finish
See Also
- 2818116 - Inline Images Not Available on the Work Description and Internal Memo Field of Ticket
- 2927768 - Error Messages Are Thrown When Copying And Pasting Content Into Ticket Description
- 3075662 - Add Images In Portal Interactions In Tickets
- 2976952 - Portal response option in Ticket Timeline is not enabled
Keywords
HTML editor, Portal messages, WYSIWYG is not loading, Inline images & text formatting, COD_SERVICE_TICKET_PORTAL , KBA , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer core applications 2208