SAP Knowledge Base Article - Public

3248279 - Data Point Comments are not returned for the private versions in SAP Analytics Cloud (SAC)

Symptom

  • When there is a Data Point Comment added to a table it can be visible. However, when the data is copied to a Private Version with the option of "Include all comments" enabled, the comments won't be visible anymore in the private version.
  • Any further Data Point Comments created in the private version won't be visible by other users even if those are shared.

Environment

  • SAP Analytics Cloud (Enterprise) 2021.15.8

Reproducing the Issue

  1. Open story with table widget.
  2. Add Data Point Comment to table.
  3. Initiate Copy Data to Private version with "Include all comments" enabled.
  4. See that the comment is not visible in the private version.

Cause

  • The root cause is related to using "Exclude filter" on "Version" dimension. The bug is that when any version member (public or private) is selected in 'Exclude' filter on Version, the expectation is that data of 'all versions' (public and private both) excluding the selected version be fetched , but in actual scenario the bug is causing 'all versions' to only consider public versions (and ignore private version). 

Resolution

  • This issue is currently under investigation by development.
  • As a temporary workaround until the fix is deployed, please avoid using exclude filter on Versions if you have private versions and instead use include filters as workaround (for selecting a subset of versions).

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

data point comments, private version, comments not visible, can't see comments, comments disappeared , KBA , LOD-ANA-CMT , SAC collaboration, commenting , Problem

Product

SAP Analytics Cloud 1.0