Symptom
The following error occurs when activating DocuSign via Admin Center > Configure DocuSign eSignature:
"Failed to get access token for OAuth flow: consent_required - Envelope could not be sent to DocuSign because the consent for SAP SuccessFactors has been revoked. Please reactivate DocuSign in Configure DocuSign eSignature."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to Admin Center > Configure DocuSign e-Signature.
- Enter the following information:
- DocuSign User ID:
- DocuSign API Account ID:
- Environment:
- DocuSign User ID:
- Under the DocuSign Consent Agreement (for production/sandbox environment), check the box for: ☑ Yes, I have read and accepted the DocuSign Consent Agreement.
- Activate.
- Error: "Failed to get access token for OAuth flow: consent_required - Envelope could not be sent to DocuSign because the consent for SAP SuccessFactors has been revoked. Please reactivate DocuSign in Configure DocuSign eSignature."
Cause
- Cause #1: The DocuSign credentials provided is being used for both Production and Test (Sandbox) environments, which is causing the issue.
- Cause #2: The DocuSign credentials provided are linked to a Development environment -- which is not supported by the SAP DocuSign eSignature configuration. The system only recognizes Production and Sandbox environments. As a result, the integration cannot function correctly with the current credentials.
Resolution
Please maintain separate DocuSign accounts for each environment (Production and Test) to ensure proper configuration and avoid integration issues.
See Also
Keywords
onboarding, docusign, activate, account, envelope, failed to get access token, OAuth flow, consent_required, envelope not sent to docusign, reactivate docusign, configure docusign esignature , KBA , LOD-SF-OBX-DSN , Docusign Integration , Problem
SAP Knowledge Base Article - Public