Symptom
When a admin user tries to change the author a report from user X to Y, user Y doesn't show up while searching.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
- Report Center Listing & SOLR Issues
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
Reproducing the Issue
- Login into instance
- Navigate to Report Center
- Try to change the author of any report from existing user to "Y"
- Can see that user "Y" doesn't show up while searching
Cause
User X trying to change the author of the report to Y doesn't have access to view user "Y" in Employee Profile.
Resolution
Provide access to user "X" to view the Employee Profile of "Y".
Once the access is provided we can change the author name of report to "Y".
Keywords
Employee, Profile, Change, Author, Report, Center, Search, Access , KBA , LOD-SF-ANA-RCT , Report Centre , How To