Symptom
A timeout error occurs, or the page keeps loading indefinitely, when exporting BPs in bulk using the Manage Business Partner Master Data app.
Environment
SAP S/4HANA Cloud Public Edition
Cause
When exporting a large number of records (e.g., over 10,000), the list report page, although it shows the total record count, does not load all records at once. It initially loads a limited number of records, say 200, and then loads another 200 when you scroll down. However, when you export a large number of records, the app attempts to load all records at once, which leads to performance issues.
Resolution
Please limit the number of records by adding more filters.
Keywords
timeout, Export BP, S/4HANA Cloud, Manage Business Partner Master Data, performance , KBA , LO-MD-BP-ODT , OData Service for Business Partner , Problem
SAP Knowledge Base Article - Public