Symptom
Existing Candidates are getting a message "There's already a profile associated with the email address you provided, so we can't create a new profile." when submitting a data capture form.
Environment
SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- Candidate receives a link of the landing page with data capture form from the recruiter.
- Candidate fills up all the required fields and submit.
- Message showing "There's already a profile associated with the email address you provided, so we can't create a new profile."
Cause
- The link of landing page with Data Capture form the existing candidate is using did not came from an email campaign.
- The recruiter did not use the "link icon" in the email campaign when adding the URL of the landing page.
Resolution
This is an expected generic message that the existing candidates will receive if they try to submit a data capture form that did not came from an Email Campaign. This message cannot be customized or updated. In order for the existing candidates to successfully fill up and submit the data capture form, the recruiter must send link of the landing page to the candidates using Email Campaign. On then that their account will be authenticated and be able to update their candidate profile. The recruiter also needs to make sure that the URL of the landing page was added using the link icon when creating email template for the email campaign.
See Also
User Assistance Document - Data Capture Forms for New and Existing Candidates
Keywords
Existing candidate, submit, DCF, error DCF, existing, email, campaign , KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , Problem