Symptom
Product Catalog Zip file does not show files in File Explorer
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Product and Service Portfolio work center.
- Go to the Product Catalogs view.
- Open a catalog
- Navigate to the Product Search tab.
- Add a zip file as attachment
- Then download it using "download all" button
- Open that zip file in file explorer.
- You will not see any files
Cause
This behaviour is a current limitation due to the file names in the Zip folder.
Resolution
The reason why the zip file is not working is because the files inside have a name like: /BOAttachments/xxxxxxxxxxxxxxxxxxx/XXXXXX_F5.jpg.
The leading "/" is the issue, the name should instead be BOAttachments/xxxxxxxxxxxxxxxxxxxxx/XXXXXXXXF5.jpg.
You can remove the leading "/" from the file name and upload it.
We have taken this limitation into our backlogs and it might be considered in one of the future releases.
Keywords
Product Catalog, Zip files, File Explorer, attachments. , KBA , AP-RC-DOC , Document Centric Application Service , Product Enhancement