Symptom
- Inbound/Outbound e-mail communication (E-Mail Communication Channel) is not visible in Agent Desktop (add-on) Customer Hub Timeline
- For example, e-mails which create tickets via e-mail channel or e-mail replies done from a ticket are not visible in AD Customer Hub Timeline
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Send an e-mail to a corresponding e-mail channel
- Ticket gets created
- Go to Services -> Agent Desktop (AD)
- Search for a Business Partner (BP) and confirm it
- Navigate to the Customer Hub and check under the timeline
Cause
System is working as designed
Resolution
- The Agent Desktop Add-on (AD) does not currently support Communication Channels which are not natively handled in AD
- Since Communication Channels that create tickets are not native to AD, these interactions will not be displayed in the Customer Hub Timeline for the AD
- AD was designed to handle real-time interactions directly performed in AD via the CTI widget, and such interaction will be displayed in the customer timeline as expected
- For AD, Communication Channel Integration is enabled by third-party communication system providers (CTIs)
- The system is working as designed
- Do you feel the scenario described should be included as an enhancement? If so, please submit your feature request via the SAP Customer Influence site. See KBA 3295509.
- Need Customer specific development?
- With SAP Cloud Service Center, you also have the option to receive a customer-specific development.
- Find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html
- If you are a partner: please use “cloudsolutionpartner@sap.com” or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html , choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
Keywords
Agent Desktop, Customer Hub Timeline , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2208