SAP Knowledge Base Article - Public

3250064 - Locked Error Message when Creating Sales Orders through Web Service

Symptom

You are receiving the error message "ATP check not possible; material locked by user" when creating sales orders through Web Service.

Environment

SAP Business ByDesign

Reproducing the Issue

When creating sales orders through Web Service, occasionally you are receiving the following error message.

<Note>ATP check not possible; material locked by user </Note>

Cause

Once creating a Sales Order with a specific Product, the system automatically "block" the product in a way to guarantee the quantity required in the stock of this product.

When you do it simultaneously with many Sales Orders with quantities that for some reason are more than the quantity you have available, the system will not be able to confirm, and it will show you the error you are facing.

Resolution

This is the expected system behavior, because it avoids you to sell more quantities than you really have.

For this case, there are two suggestions.:

- You can resend the call which fails with the error mentioned after sometime or;

- You can schedule a delay between the calls sent, in order to avoid this simultaneously lock.

Keywords

Sales Order, Web Service, lock , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions