SAP Knowledge Base Article - Public

3251501 - Customer Hub View does not open with new inbound phone call while using the Live Activity

Symptom

  • You are using the Live Activity and configured it to open the customer hub when a call arrives
  • The expectation is that the Customer Hub window will open, but that does not happen with the inbound call
  • However, the Customer Hub window opens when making an outbound call

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Place a call or simulate a call
  2. Widget opens up
  3. Confirm the customer/contact
  4. Customer Hub does not open

Cause

One possible cause is a mismatch on the Comm System ID maintained on Live Activity Configuration.

Resolution

  • For an activity to be created when a phone call is accepted, your widget integration must have a Comm. System ID defined
    1. Go to Administrator
    2. Click "Service and Social"
    3. Navigate to and client on "Live Activity Configuration"
    4. See under Fiori Client Settings, and enter a value in the "Comm. System ID" field. For example, "Contact_Center".
  • If you are accepting a Whatsapp message, check if an Activity is created under Activities - Messaging

            If Activity is not created, recheck your scoping question:

                

  • The Comm. System ID can then be maintained under the "Communication Systems" using the following steps:
    1. Go to the Administrator work center
    2. Select the General Settings view
    3. Open Communication Systems
      • If there was no Comm. System ID, then create a one
        1. Click "New"
        2. Under "Basic Information", enter the "ID" (for example, Contact_Center), "Host Name = Contact_Center" and "System Type = Internet"
        3. Go to System Instances and click "Add Row"
        4. Enter System ID = Contact_Center and Preferred Application Protocol = 5 - Web Service
        5. Click "Save and Close"
      • If there was already one created, then ensure the Communication System ID is exactly the same as what was defined in the Live Activity Configuration (Comm. System ID field) AND "In Use" field is enabled

    See Also

    • 3058164 - Internal Memo Not Visible on Customer Hub
    • 3087255 - Unable to Hide the Timeline in the Customer Hub Screen
    • 3208915 - Live Engagement widget does not load the widget or the telephone icon is missing

    Keywords

    CTI ; live activity ; inbound call ; outbound call ; activity ; customer hub ; opened ; opening whatsapp ; message , KBA , LOD-CRM-LA , Live Activity , How To

    Product

    SAP Cloud for Customer core applications all versions