SAP Knowledge Base Article - Preview

3252460 - Java instance fails to start with errors: "Input data length not a multiple of blocksize" or "invalid: software version 7.00.000.001 is incompatible with file version 7.50.000.00#" during system copy of SAP NetWeaver 7.50 using SWPM tool.

Symptom

Target system installation of SAP NetWeaver 7.50 AS Java with SWPM Tool (SAP Note: 1680045) fails in Java start step:

sapinst_dev.log:

...

The step startJava with step key |<...>|ind|ind|ind|ind|0|0|startJava was executed with status ERROR (Last error reported by the step: Instance SAP<SID>/<instance name> reached state UNKNOWN after having state BOOTSTRAP. Giving up).

...

The following error entries are written into

jvm_bootstrap.out, when the AS Java system is freshly installed on the target side:

...

Exception occurred for component [internal/unkown] of type [unkown]
com.sap.engine.bootstrap.SynchronizationException: Cannot read manager  properties from database. Check database consistency
...
----------==[ Caused by: ]==----------
com.sap.engine.lib.config.api.exceptions.ClusterConfigurationException: Cannot retrieve the configuration structure corresponding to manager name LicensingManager.
...
Caused by: com.sap.engine.frame.core.configuration.ConfigurationException: Internal error during the decryption process.
...
Caused by: com.sap.security.core.server.secstorefs.InvalidStateException: Internal error during the decryption process.
 at com.sap.security.core.server.secstorefs.Crypt.decrypt(Crypt.java:859)
 at com.sap.security.core.server.secstorefs.SecStoreFS.decrypt(SecStoreFS.java:3454)
 at com.sap.engine.core.configuration.impl.security.CrypterImpl.decryptBytes(CrypterImpl.java:194)
 ... 21 more
Caused by: javax.crypto.IllegalBlockSizeException: Input data length not a multiple of blocksize.

or this into log_bootstrap, if the key phrase was changed and bootstrap was started afterwards

...

com.sap.engine.frame.core.configuration.ConfigurationException: Error while connecting to DB.

...

Caused by: com.sap.security.core.server.secstorefs.FileInvalidException: File "/usr/sap/SAP<SID>/SYS/global/security/data/SecStore.properties" is invalid: software version 7.00.000.001 is incompatible with file version 7.50.000.005.

           at com.sap.security.core.server.secstorefs.SecStoreFS.checkCompatibility(SecStoreFS.java:1933)

            at com.sap.security.core.server.secstorefs.SecStoreFS.openExistingStore(SecStoreFS.java:2008)

            at com.sap.sql.connect.OpenSQLConnectInfo.getStore(OpenSQLConnectInfo.java:793)

            at com.sap.sql.connect.OpenSQLConnectInfo.lookup(OpenSQLConnectInfo.java:784)

            at com.sap.sql.connect.OpenSQLDataSourceImpl.setDataSourceName(OpenSQLDataSourceImpl.java:130)

            ... 14 more


Read more...

Environment

  • System copy of SAP NetWeaver 7.50 AS Java with SP24 and higher
  • DSS split of SAP NetWeaver 7.50 AS Java with SP24 and higher

Keywords

SWPM, System copy, Java start,  , KBA , BC-JAS-COR , Enterprise Runtime, Core J2EE Framework , BC-JAS-SF , Startup Framework , BC-JAS-SEC , Security, User Management , BC-INS-JCI , Java component inst. / jload jmigmon, jsizecheck , BC-INS-SWPM , Installation with Software Provisioning Manager , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.