SAP Knowledge Base Article - Public

3252554 - Error "Failed to create interaction, please contact your administrator in Agent desktop" after accepting a phone call

Symptom

Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales 

Reproducing the Issue

  1. Receive a phone call in C4C
  2. Accept the call
  3. Customer Hub window opens while in the Agent Desktop 

Cause

Potentially bad payload

Resolution

  • Typically such cases are caused by incorrect or invalid phone number passed by the CTI via the payload
  • Ensure that the CTI passes the correct payload per "Phone Events and Payload"
  • Pay special attention to the ANI (Automatic Number Identification) parameter.
    • ANI cannot contain extra data
    • Typically must be in Canonical format
  • Tip: you can identify the payload testing in Chrome (Dev tools) and looking under the Network tab and filter by "phoneCalls"
    1. Before reproducing the issue, launch Chrome Dev Tool (Ctrl+SHIFT+I)
    2. Click the Network tab and enter "phoneCalls" in the filter
      Dev_Tools.png

    3. Then scroll down to find the call and check the payload, preview and the response

      Check_Payload.png

Keywords

Error, Interaction, Customer Hub, Activity, AD, Agent Desktop , KBA , failed to create interaction , agent desktop , LOD-CRM-LA , Live Activity , LOD-CRM-SBS-AC , Agent Console Add-on , Problem

Product

SAP Cloud for Customer core applications 2208