SAP Knowledge Base Article - Public

3253046 - Email Field Empty in Job Application for Internal Candidates - Recruiting Management

Symptom

Email field is empty/null in the Job Application form despite being a required field. This happens only to Internal Candidates.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Internal Candidate applies to a Job Requisition;
  2. The Candidate provides the email value and submits the Job Application;
  3. Recruiter opens the Job Application and the email value is empty.

Cause

The scenario will occur only with specific conditions:

  • The Email field is SM-Mapped between Recruiting and Employee Profile;
  • The User/Internal Candidate does not have the ability to edit the Email field in the Candidate Profile, only in the Job Application;
  • The Email field is empty on both Recruiting and Employee Profile sides.

With the above conditions, as the User/Internal Candidate doesn't have the ability to edit the Email field in the Candidate Profile, the system will allow the User to proceed to the Job Application, without asking to complete the Candidate Profile Email field, then the Email field will be inserted but the synch will not occur as the User must have the ability to edit the field on both Candidate Profile and Job Application sides. Then, after the User applies, the email value will be presented in the Job Application and it can be even reported however, as soon as the first Operator opens the Job Application, the system removes the value during the snapshot, as part of an internal backend job which validates User Profile's email field, which is also empty, hence the value from the Job Application is removed.

This behavior has been analyzed and addressed as expected.

Resolution

To avoid the described issue, make sure the User has a valid email in their Employee Profile if the field is SM-Mapped with Recruiting.

After fixing the issue, it would still be required to update the Email value for the affected Job Applications. In this case, you can refer to the following options:

  • Granting Application Snapshot permission to the Recruiting Operators. With this approach, Recruiting Operators will be able to edit the fields over the top card on the Job Application, including the Email field - 2081624 - Edit Candidate Profile Snapshot - Recruiting Management.
  • Edit the Email field via OData API - 2882860 - How to edit Job Application data via ODATA API - Recruiting Management.

Keywords

email, missing, job, application, internal, field, empty, null, synch , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions