Symptom
When accessing the Drill-to-Detail (D2D) of some measures, an application occurs. The metric is accessible and page displays, the issue only happens when trying to access DTD. The issue appears to be specific to the customer instance since DTD is working for other customer instances.
Environment
SAP SuccessFactors Workforce Analytics
Reproducing the Issue
1. Login to analytics site (or go to SF BizX > main menu > Workforce Analytics)
2. Change to affected Org ID (If in Analytics site)
3. Try to access the DTD of the measures listed e.g.
Promotion Rate – In,
Transfer Rate – In,
Demotion Rate – In,
Termination Rate – Voluntary
Termination Rate – Involuntary
Termination Rate - 10-<15 Years Tenure (Voluntary)
Retirement Rate
Result: None is available
4. Go to WFA on HANA Data Factory page
Result : An inconsistency in the data associated with the page you have requested has been detected and the application is unable to process your request.
Details of the problem have been logged to enable SuccessFactors staff members to review this issue.
Cause
This can happen if the company only has one Fact table. You can check this in the Data Factory (or for support the backend log viewer).
Resolution
Fact Tables need to be created by correcting the configuration and rebuilding the WFA cube.
Since it's a failure with the tables during initial build, this can be consulted over at the Partner Delivery Community (PDC)
Please refer to:
2850225 - WFA on HANA - Implementation query & Handling process
See Also
2850225 - WFA on HANA - Implementation query & Handling process
https://launchpad.support.sap.com/#/notes/2850225
Keywords
application error, d2d, drill to detail, metrics, measures error , KBA , LOD-SF-WFA-WA , Workforce Anaytics , How To