SAP Knowledge Base Article - Public

3253532 - No time recording can be found in Time Sheet UI even though the time events are paired successfully.

Symptom

After configuring Clock In Clock Out Time Type Derivation Configuration by defining Time Types used for pairing of time events, time events are getting paired but Recorded Time / Working Times still shows Zero hours or there is no corresponding Working time record in the Time Sheet UI.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors Time Tracking - Clock In Clock Out

Reproducing the Issue

  1. Create time event via manual creation, Clock My Time quick action, Mobile, or import etc.
    You are able to find the time events from Time Sheet UI.
    2.PNG
  2. Time Events were successfully paired as checked from in Manage Clock In Clock Out.
    4.PNG
  3. But no time recording shown in Time Sheet UI>
    3.PNG

Cause

The generated External Time Data is either in New status not yet processed, or in Error status failed in processing.

Resolution

    1. Go to Manage Clock In Clock Out and navigate to the corresponding paired time events. 
    2. Click on the Copy Pairing ID icon for the second time event.
      copy.png
      This Pairing ID is the external code of the generated External Time Data.
    3. Go to Manage Data and search for the External Time Data with the copied ID.
      • If the Status is Error, it means the import of the generated External Time Data failed. 
        To get the reason behind the failure, please 
        • EITHER
          1. Go to Admin Alerts tool.
          2. Select Import Time Sheets as the Admin Alert Type.
          3. Search for the alert of the particular user.
            The alert message tells you the reason of the failure of external time data processing, like collision, missing main attendance time type, missing default import attendance time type, or others.
          4. Please correct the data or the configuration.
          5. Then please set the status of the External Time Data from Error to New and save.
            This will trigger a new round of processing of external time data. 
            As long as the data or configuration issue is solved, the processing should be successful and the status of the External Time Data will be set to Processed.
          6. Then you will find the recording from Time Sheet UI.
        • OR
          1. Go to Administer Time of the employee.
          2. Go to Time Alerts tab.
          3. Then you will see the Import Time Sheets alert.
            The alert message tells you the reason of the failure of external time data processing, like collision, missing main attendance time type, and others.
          4. Please correct the data or the configuration.
          5. Then please set the status of the External Time Data from Error to New and save.
            This will trigger a new round of processing of external time data. 
            As long as the data or configuration issue is solved, the processing should be successful and the status of the External Time Data will be set to Processed.
          6. Then you will find the recording from Time Sheet UI.
      • If the Status is New, it indicates the generated External Time Data is not processed yet.
        • Ensure in Time Management Configuration object, the field 'Disable Instant Import of Time Sheet Data' is set to 'no' as per KBA 2854180 - Time Sheet: Instant Import Of External Time Data can be referred to.
        • Check the points in KBA to 3413476 to avoid delay in External Time Data processing.

      • If the External Time Data cannot be found in Manage Data, there could be error during the External Time Data generation process.
        1. Please navigate to Admin Alerts Tool.
        2. Select Admin Alert Type "Processing Paired Time Events for Time Sheet".
        3. Check if there's any error message for the employee. 
          The Error message could be parallel import, duplicate External Time Data or triggered by External Time Data validate rule. 
        4. Please fix the issue manually by correcting the data if the error message is customized.
        5. Select the Alert message, click Action button - choose Reprocess. 
        6. The External Time Data should be generated again. 

See Also

  • SAP Help Portal Documentation: Import of External Time Data
  • KBA 2854180 - Instant import Of External Time Data and External Allowance in Time Sheet
  • KBA 3413476 - New status External Time Data or External Allowance pending

Keywords

CICO, Clock In Clock Out Time Type Derivation, Working Times, Default Import Attendance Time Type, externaltimedata, etd, external, time, data, processing, error, new, processed, punch, time, event, pair, tms, timesheet, time sheet, attendance, time sheet entries, Time Events , KBA , LOD-SF-TTR-CIO , Clock In/ Clock Out , LOD-SF-TTR , Time Tracking , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Time Tracking all versions