Symptom
The user is unable to define the different delivery delivery schedules because in Tab "Planning Delivery Schedule" when clicking on the field "Generate Plan delivery schedule" or "New delivery schedule w/o proposal", the system overwrites the previous delivery schedule instead of creating another one.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Log on to the SAP Fiori launchpad as an Internal Sales Representative.
- Open Manage Sales Scheduling Agreements (F3515).
- On the Manage Sales Scheduling Agreements screen, choose Create Scheduling Agreements.
- On the Create Scheduling Agreements screen, make the following entries and choose Continue:
Sched. Agreement Type: choose from LZ,
Sales Organization: 1110
Distribution Channel: 10
Division: 00 - On the Create Sched. Agr. w/Rel: Overview screen, make the following entries:
Sold-To Party: 11100003
Ship-To Party: 11100003
Customer Reference: Purchase scheduling agreement number from customer
Material Number: TG11
Customer Material: RM129 - Choose Save.
- Make a note of the scheduling agreement number: __________.
- If you have created a scheduling agreement with the same data in your system and you use material TG11 and customer 11100003, the following warning may appear: There is already a scheduling agreement with this same data.
- To skip this warning, choose Enter.
*Data taken from SAP Test script of scope item 3NR.
Cause
Expected system behaviour
Resolution
- The sales scheduling agreements with delivery schedules are designed so that the buyer can regularly send new forecast delivery schedules and just-in-time (JIT) delivery schedules. Planning delivery schedules are for internal use only. Every delivery schedule contains information on the cumulated received quantity and a set of schedule lines to be delivered. The system implements a new delivery schedule by replacing the old one entirely. This means a new delivery schedule header (which includes, for example, the delivery schedule number, delivery schedule date, and the cumulated received quantity) will be created, the header of the previous delivery schedule will be deleted, and a new set of schedule lines will completely replace the previous schedule lines. In other words, the buyer informs you of the quantity they have already received and the additional schedule lines to be delivered. The system calculates the cumulated transit quantity (the difference between the cumulated quantity delivered and the cumulated quantity received), and then calculates the open quantities of schedule lines in the new delivery schedule to be delivered (or produced).
- As every new delivery schedule replaces the previous one entirely, if you create a new delivery schedule, the schedule lines of the old delivery schedule will be removed. This logic applies to all delivery schedule types: forecast, JIT, and planning.
- This can be viewed the schedule lines of old delivery schedules as historical schedule lines by clicking the "Analysis" button on the delivery schedule screen.
Keywords
Sales Scheduling Agreement, schedule agreement, sales , sd , S/4HANA Cloud, public cloud, private cloud, S4HC, agreement , delivery plan, delivery plans, scheduling agreement , 3NR, Generate Plan delivery schedule , overwrite , KBA , SD-SLS-OA-SCH , Customer Scheduling Agreement , Problem