Symptom
- You are using the Live Activity.
- For every inbound phone or chat interaction processed via your CTI integration, a new activity is created in "Activities" -> "Phone calls" or "Chats."
- Your business requires that activity creation be manual and not automatic.
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Connect to the C4C tenant
- Connect to the CTI implemented for this integration
- Receive an inbound Phone Call or Chat
- After the call or chat is completed, go to Activities -> Phone Calls or Chat (notice an activity is created)
Cause
- Cofiguration (in order to the activity to be created, some configurations and payload information is needed)
- The configuration required to enable the process to automatically create an activity, requires the use of the Comm. System ID
- For the activity to be created, the CTI needs to pass the communication type = "CALL" and the Action = "Accept", for chat this would be "Chat" & "Accept"
Resolution
- The fastest and easiest way is to remove the Comm. System information in the Live Activity Configuration
- Go to Administrator -> Service and Social -> Live Activity Configuration
- Locate the Comm. System ID field, and remove any entry maintained there
- Alternatively, request your CTI vendor to change the payload and sent Notify event
- For "Phone Events and Payload"
<?xml version="1.0" encoding="UTF-8"?>
<payload>
<Type>CALL</Type>
<EventType>INBOUND</EventType>
<ACTION>NOTIFY</ACTION>
<ANI>+123456789</ANI>
<ExternalReferenceID>EA42D48FEAD3EA11AA5EBC019352B05E</ExternalReferenceID>
<ExternalOriginalReferenceID>E0163EA718FC1FFABDD5608C895AEF67</ExternalOriginalReferenceID>
</payload> - For "Chat Events and Payload"
{
"payload":{
"Type": "CHAT",
"EventType":"INBOUND",
"Action":"NOTIFY",
"Email":"Johnxyz@test.com",
"ExternalReferenceID":"ED4E4730D1C711EAAA5EBC019352B05E",
}
} - For "SMS Messaging Events and Payload"
{
"payload":{
"Type":"MESSAGE",
"EventType":"INBOUND",
"Action":"NOTIFY",
"ANI":"+123456789",
"Text":"This is SMS text",
"ExternalReferenceID":"77FB2990D24411EAAA5EBC019352B05E",
}
}
- For "Phone Events and Payload"
See Also
3251501 - Customer Hub View does not open with new inbound phone call while using the Live Activity
Keywords
Live Activity, phone call, supressed activity creation , KBA , LOD-CRM-LA , Live Activity , Problem
SAP Knowledge Base Article - Public