Symptom
The Connector to ServiceNow has been established successfully as per the user guide.
- When extracting the data from ServiceNow, it failed with the error message as below:
---------
ExtractionJob failed | source-system: SERVICENOW
| exception: java.util.concurrent.ExecutionException
| cause: java.lang.IllegalStateException: Unable to obtain the schema for table: <XXX>
--------- - Or when previewing the table, it gives the error message:
---------
Something went wrong
Error: TABLE_SCHEMA_FAILED
Error Id:*********
Socket Closed
---------
Environment
SAP Signavio Process Intelligence
Cause
The connection user for the ServiceNow Connector doesn't have enough permission to read data from the table.
Resolution
Please ask the administrator of the ServiceNow to help grant the relevant permission to the connection user as per the following documentaion
Keywords
Signavio, Process Intelligence, ServiceNow, Connector, Unable to obtain the schema for table,TABLE_SCHEMA_FAILED , KBA , BPI-SIG-PI-INT , Integration / Schedules / SQL Filter / Delta criteria , BPI-SIG-PI-DS , Data Source (CSV, Connector) , Problem