SAP Knowledge Base Article - Public

3254594 - Error when launching course - Could not update studnet online component UserCourseClientServiceImpl launchStudentCourse() failed

Symptom

Users receive an error when they try to launch a course only in Production.

An application error has occurred. Please try again.

If you have further questions or issues regarding this error, please provide the error details below to your support group.

Error message = Could not update studnet online component UserCourseClientServiceImpl launchStudentCourse() failed.
Ticket No = 289
ErrorFingerprint [exceptionRootCauseTag=7042d5b55886bdbd458059f97acbe84e40525804, exceptionStackTraceTag=83741755083c9cf7b58528b07e99e0117a3f1f7f]

Environment

SAP SuccessFactors Learning

Cause

A bad data issues was blocking the item from launching.

Resolution

Follow the steps below and it will solve the issue:

  1. Change all content objects associated to the affected item from AICC to Document Type;
  2. In the Item Level, uncheck the Complete in Sequence;
  3. Reassign the course to the user using the wizard;
  4. Go back to each object and change it back to AICC (and check the wrapper is needed);
  5. Check again the Complete in Sequence at the item level;
  6. Reassign the item again.

Keywords

Item not launching, error to launch course, exceptionRootCauseTag=7042d5b55886bdbd458059f97acbe84e40525804, exceptionStackTraceTag=83741755083c9cf7b58528b07e99e0117a3f1f7f, Could not update studnet online component UserCourseClientServiceImpl launchStudentCourse() failed, UserCourseClientServiceImpl, launchStudentCourse() , KBA , LOD-SF-LMS-CNT , Content , Problem

Product

SAP SuccessFactors Learning all versions