Symptom
The DPCS dialog (pop up window) does not open in the "Create an account" screen on the External Career site when the selected language is Spanish.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to the external career site
- Select Spanish language
- Click on Create new account
- Fill in all the details and select the country
- Click on the link to accept the DPCS
- Nothing happens, the DPCS does not open
Cause
The label for the language key "RECRUITING_MAKE_MY_PROFILE_VISIBLE_TO " in the Spanish language pack contains inverted commas which are not supported and cause the system to break.
Resolution
Remove all the commas for the label for the language key "RECRUITING_MAKE_MY_PROFILE_VISIBLE_TO" for the Spanish custom language pack and reupload the custom language pack after saving it.
See Also
2576546 - Using the Manage Language Feature to Change Labels in SuccessFactors
Keywords
DPCS, Data, Privacy, Consent, Statement, Trigger, Open , KBA , LOD-SF-RCM-POR , Career and Agency Portals , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem