SAP Knowledge Base Article - Public

3255117 - Not possible to delete scope items (scenarios) after activating it

Symptom

After adding some scope items to a SAP Central Business Configuration Workspace, completing the scope, and clicking on the Edit button in Define Scope, it is expected to be able to delete (remove) some unwanted (or no longer needed) scope items. However, the remove button is greyed out.

OR 

If the system is a Manage Your Solution, after adding scope items, it is intended to request the deletion of unwanted (or no longer needed) scope items.

Environment

  • SAP Central Business Configuration.
  • SAP S/4HANA Cloud Public Edition.
    • Valid for 2SL and 3SL environments
    • Valid for Manage Your Solution 

Cause

The scope item selection cannot be changed once the Scoping is completed or if the workspace deployment has already been performed to the target system.

Resolution

Once the scoping is completed or the deployment performed the selected scope items cannot be deleted (removed) anymore. 

On this SAP Help page Editing Scope there is an warning note that highlights:

  • You can only add scope. It is not possible to delete any countries/regions, bundles, or scenarios. These choices are irreversible.

To avoid any activation issues, review the workspace scope before changing the Define Scope workspace activity status to Completed (by choosing Complete Activity). Refer to SAP Help Portal Defining Scope.  

Note:

In SAP Central Business Configuration, the scope items will be deployed to the S4 target system once the decision to deploy the scope and organizational structure to the target system is made, following the instructions in the SAP Help Portal Deploying Scope and Organizational Structure.

While there is no deployment to the target system yet, it is still possible to delete the Workspace as described in the SAP Help Portal Deleting a Workspace.

If the workspace is already deployed then the workspace deletion is not possible anymore, and the only way to remove the scope item from the system is to perform a system reprovision. Note that system reprovisioning will remove all configurations and deployed data from the system, and the system setup process must be redone from scratch. 

If the workspace deployment has been performed, there are two options:

  • Customer systems: If the reprovision is necessary, open a new ticket with a written approval to start the system reprovisioning process. (Component XX-S4C-OPR-SRV)
  • For Cloud test, demo, and development for SAP S/4HANA Cloud system, contact the partner delivery support team at TDD@SAP.COM for further instructions regarding the closure steps. After the current entitlement is closed, a new license must be subscribed to, which will provide a new entitlement for provisioning. For a Cloud test, demo, and development for SAP S/4HANA Cloud system, this is the only way to get newly provisioned system and start from scratch.

See Also

Keywords

CBC, MyS, Manage Your Solution, unwanted, Delete scope item, remove scope, delete scope bundle, scope scenario, define scope, define scope, edit, changes via edit, edit button, reviewing your scope. , KBA , CBC-BOS-ANS , Add New Scenarios (aka Scope Items) , XX-S4C-OPR-SRV , S/4HANA Cloud service requests , Problem

Product

SAP S/4HANA Cloud Public Edition all versions