SAP Knowledge Base Article - Public

3255284 - Time Events not syncing with Working Time when conflicting overtime request exists

Symptom

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“

  • Working time is not updated even after conflicting overtime request is removed /deleted
  • Time Events not syncing with Working Time when conflicting overtime request exists

Environment

 SAP SuccessFactors Time Tracking Clock In Clock Out

Reproducing the Issue

  1. Create an Overtime Request in employee Time sheet UI say on 3rd October 2022
    Overtime request.PNG 
  2. Insert Clock in Clock Out Time events from Manage Clock In Clock Out or  Terminals  on the same day
    manage clockinout.PNG
  3. Go to Time sheet UI of the employee for the collision error :
    Your time sheet entries were not successfully imported from an external system. Please contact your administrator. Reason: Resolve overlapping time sheet entries on Oct 3, 2022. Make sure there is only one time entry between 2:00 PM and 4:00 PM. If you record night shifts, check the previous and the next week of the time sheet for possible overlaps. If you have edited an approved time sheet, please contact your system administrator
    Time sheet Error.PNG
  4. Now delete the Overtime record from Time sheet UI and refresh the Page . The error still remains.
    Your time sheet entries were not successfully imported from an external system. Please contact your administrator. Reason: Resolve overlapping time sheet entries on Oct 3, 2022. Make sure there is only one time entry between 2:00 PM and 4:00 PM. If you record night shifts, check the previous and the next week of the time sheet for possible overlaps. If you have edited an approved time sheet, please contact your system administrator
    Without Overtime.PNG

Cause

  • Time alerts under Administer Time of the employee still contain the error message
    Time alerts.PNG

Resolution

  1. Once  conflicting ‘Overtime’ Time request for was removed,go to Time alerts under Administer time for the user,and
    under View Actions--> Run Time sheet Import again .
    Import time.PNG
  2. This will correct the error status of the external data, and will sync the working time as per time events.
    The error messages as seen above will now be resolved (under View 2 Messages)
    Run Import.PNG
  3. Refresh the Time sheet UI of the employee.The Time Events for the user as above will sync with Working Time.
    corrected Time sheet UI.PNG

Keywords

cico,Clock, In, Out, Clock-in Clock-Out, Time Tracking , KBA , LOD-SF-TTR-CIO , Clock In/ Clock Out , LOD-SF-TTR-TMS , Time Sheet , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Core all versions ; SAP SuccessFactors Time Tracking all versions