SAP Knowledge Base Article - Public

3256112 - Technical User Being Locked Automatically by the System

Symptom

Technical User gets locked automatically by the system, even after unlocking the user.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management Work Center.
  2. Go to the Support and Technical Users view.
  3. Search for and select the particular user.
  4. You can see that the box "Password Locked" is checked.

Cause

The Technical user is being locked because of too many failed authentication attempts with incorrect password. Could be because of the following reasons.

  1. The old password was saved in the browser, hence even after the password changed the browser is still trying to login with the old saved credentials.
  2. The Technical user are being used in some communication scenario. After changing the password, The client was continuously trying to login with the old password this results in the password  locked due to multiple incorrect logon attempts.

Resolution

  • First thing we would suggest is to check if that Technical user is used in any web services and to check if there could be places where some client is trying to log in with persisted (old) password.
  • If above does not solve the issue, we would suggest to change the User ID to something else so that the incorrect logon attempts do not affect this user ID

Keywords

Technical user, locked, user locked, password locked, automatically. , KBA , technical user locked , user locked , password locked , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Business ByDesign all versions