Symptom
The KUT field is showing the technical ID name instead of the field label/description.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to E-Mail Integration WoC.
2. Open the Groupware Settings.
3. Go to Profiles.
4. Open "123"(123 represents the profile name) profile.
5. Go to ADD_IN SETTINGS tab.
6. The field "ABC" (ABC represents the field name)is showing the field ID instead of the label.
Cause
Usually this issue happens when the field label was created after the field being added to the OData.
Resolution
You need to create the field description before add the field to the OData service.
To solve it, you need to remove the field from the OData service and add it again.
1. Open the document.
2. Enter on Adaptation Mode.
3. Edit the "ABC" (ABC represents the field name) field and click on oData.
4. Delete all extension.
5. Save.
6. Exit Adaptation Mode.
7. Close session.
8. Then, add the field back to the OData service.
P.S.: The issue can also happen in case there is no English label to the field.
Keywords
KUT, Field, Groupware, ID, Label, Description , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To