Symptom
Possible reasons for error 'Customer/vendor does not have any allowed bank details' in Manage Automatic Payments App.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Create payment proposal or payment run in Manage Automatic Payments App. It fails due to error. Checking the Log the following error occurs:
1st Case
> Partner Ctry/Reg./partner bank Ctry/Reg. is not permitted
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
2nd Case
> Bank & / & / & is not a domestic bank
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
3rd Case
> No payment method with QR-IBAN payment procedure defined
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
4th Case
> Collection authorization does not exist for bank key & account &
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
5th Case
> Bank details & / & / &: IBAN is not valid or Bank details & / & / & do not have an IBAN
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
6th Case
> Country/Region & of bank details & / & is not a memeber of the EU
> Customer/vendor does not have any allowed bank details
> No permitted payment method exists
Cause
Incorrect customizing.
Resolution
1st Case
Maintain reported country/region as permitted destination country/region for Payment Method/Country in SSCUI 101972.
2nd Case
Set indicator 'Cust./Vend. Bank Abroad Allowed?' in SSCUI 101044 for company code and payment method.
3rd Case
The error comes if partner bank account in the payment proposal/run has QR-IBAN. Invoices with QR-IBAN must have QR-IBAN entered into the document along with QR Reference.
If the company code is not QR-Bill enabled (no parameter set in SSCUI 102739) use regular IBAN for payment instead of QR-IBAN.
4th Case
If an alternative payee including bank data was maintained for the item, this means the partner bank data is not taken over from the business partner master data
where the collection authorization for bank account is granted. Instead the bank data from the alternative payee/payer in the document is used where it is not possible to give the collection authorization. The payment method in country/region, however, does require a collection authorization.
In such case there are two possibilities:
- deselect 'Collection authorization' for the used payment method in SSCUI 101972.
- or use another payment method without 'Collection authorization'.
5th Case
Check in BP master data in Maintain Business Partner App under tab Payment transactions the IBAN the Validity From date.
6th Case:
"EU Internal Transfer" is flagged in SSCUI 101972 / Activity "Set up Payment Methods for Each Country/Region" under "Payment method classifcation" and the Business Partner has "Bank Country/Region Key" out of the EU (for example CN) in BP master under Payment Transactions General Data.
According to F1 Help:
"Select this indicator if the payment method for the transfer of small amounts of money between member states of the European Union is to be used (the EU internal transfer)."
See Also
2671294 - No Valid Payment Method Found
Keywords
Manage Automatic Payments, customer, vendor, bank details, no permitted payment method, SSCUI 101044, SSCUI 101972, F0770, F 0770 , KBA , FI-FIO-AP , Fiori UI for Accounts Payable , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem