SAP Knowledge Base Article - Public

3256968 - Custom BIRT templates reports stopped working after B2211 release

Symptom

  • Custom BIRT templates reports stopped working after B2211 release.
  • BIRT template scheduled stopped working.

Environment

SAP SuccessFactors HXM Suite

Cause

This behavior is caused because you might be running your BIRT table report on older version(2.6) of BIRT.

Business Intelligence Reporting Tool (BIRT) is a third-party solution which is used to create data visualization within SuccessFactors. In 2018, SAP SuccessFactors moved to BIRT 4.3.2 as a standard for our table reporting tool output framework. With that update, some customers remained on BIRT 2.6 due to reports having poor query development or display issues within the BIRT 4.3.2 framework.


Since the announcement in 2018, SAP SuccessFactors has reached out to work directly with your organization to upgrade to BIRT 4.3.2. With the Second Half 2022 release, based on security updates, SAP SuccessFactors will upgrade the data center infrastructure. With this change BIRT 2.6 can no longer be supported in our data centers, therefore, the upgrade to BIRT 4.3.2 will become mandatory. We apologize for the short notice as this incompatibility was recently confirmed. Security is of utmost priority to us and BIRT 2.6 is not compliant with the latest security standards.

 
With the Second Half 2022 Preview release, your Preview tenant will be upgraded to BIRT 4.3.2. We recommend once the release is applied that you validate your Custom BIRT reports for compatibility. This will provide insight into potential action required for your Production reports when the Second Half 2022 release is applied in December.

Resolution

    While you are validating the custom BIRT reports, if you encounter any issues we recommend you reach out to your preferred SAP Partner or SAP SuccessFactors Professional Services to assist in adjusting the reports for the BIRT 4.3.2 framework.

    • If the engagement of SAP Professional Services is required, it is through a paid engagement that will be quoted by this team. You can open a case directly to LOD-SF-SER-ANA component, so this team will assess the requirement.
      • In case any clarification/general query on this topic, you can reach out to PeopleAnalytics@sap.com alias, so the topic will be answered by an account team.

      Keywords

      KBA , LOD-SF-ANA-BIR , BIRT Reports , Problem

      Product

      SAP SuccessFactors HCM Suite all versions