SAP Knowledge Base Article - Public

3258133 - Inactive users appearing in search history of SF Mobile

Symptom

  • Inactive users are appearing in the search bar in SF mobile application. 
  • A user was made inactive and is still appearing in the search function in SF mobile. 

Environment

SAP SuccessFactors HXM Suite Core 

Reproducing the Issue

  1. Log onto system and activate the SF mobile application. 
  2. In the mobile app - search for user A.
  3. Logout of the mobile app.
  4. Go back onto SF desktop version. 
  5. Mark user A inactive on the system. 
  6. Activate the Mobile App again and log on. 
  7. Search for user A who was made inactive and see the user still appear in the results/search history

Cause

This is expected behaviour by the system as the server that handles the mobile app does not recieve a signal to remove this from the search history of the app. 

Resolution

Expected behaviour of the search functionality in mobile. 

See Also

Keywords

Inactive user, SF Mobile, Mobile app, Search , KBA , LOD-SF-PLT-MOB , Mobile Issues , Problem

Product

SAP SuccessFactors HCM Suite all versions