SAP Knowledge Base Article - Public

3258168 - Extension Field on Item Node of Service Request BO Does Not Work on the Rules for Product and Item Processing Type

Symptom

You created an Extension Field on the Item node of the Service Request Business Object in C4C and added it in the Rules for Product and Item Processing Type table, however, upon receiving data from FSM, you notice that the data for the extension field is not considered, hence, the corresponding product or item is not determined.

Environment

SAP Cloud for Customer

Cause

The system does not support extension fields from the Item node of the Service Request business object to be added in the rules, as of now, only the extension fields added in the Root node can be used.

Resolution

This feature is not supported in the current release of SAP Cloud for Customer.

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  2. If you are a customer:
    1. Contact your Account Executive.
    2. Check the link for SAP Advisory Services.

An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:

SAP Service Cloud

Keywords

Item, Node, Root, Extension, Field, Extension Field, Service Request, BO, Business Object, C4C, FSM, KUT Field, KUT, Rules for Product and Item Processing Type, , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions