Symptom
- You have integrated SAP Cloud for Service Live Activity to create activities from chat (see "Record Chat Activities")
- The CTI is passing the transcript information in the payload but there is still no chat transcript shown in the activity
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Service
- SAP Cloud for Sales
- C4C
- Live Activity
Reproducing the Issue
- Start a chat
- Accept the chat
- Confirm an account, individual customer or contact and start chatting
- End the chat
- Check the chat transcript by either going to:
- Customer Hub -> Timeline -> Chat -> View Transcript or
- Go to Activities -> Chat -> Open the chat activity in question
Cause
- Missing or incorrect configuration
- Missing or incorrect payload
Resolution
- Ensure the "Comm. System ID" maintained under the Live Activity Configuration is also maintained under the "Communication Systems" using the following steps:
- Go to the Administrator work center
- Select the General Settings view
- Open Communication Systems
- If there was no Comm. System ID, then create a one
- Click "New"
- Under "Basic Information", enter the "ID" (for example, Contact_Center), "Host Name = Contact_Center" and "System Type = Internet"
- Go to System Instances and click "Add Row"
- Enter System ID = Contact_Center and Preferred Application Protocol = 5 - Web Service
- Click "Save and Close"
- If there was already one created, then ensure that the ID is exactly the same as what was defined in the Live Activity Configuration AND "In Use" field is enabled
- Specially the System Instance ID, which in this example is "Contact_Center"
- It is important that both the Communication System ID and the Business Instance ID are the same as the one maintained on the Live Activity Configuration
- Ensure that your CTI sends the correct payload to C4C.
- For example:
payload -:-{
"Type":"CHAT",
"EventType":"UPDATEACTIVITY",
"Action":"END",
"Email":"Peter.Parker@test.com",
"ExternalReferenceID":"ED4E4730D1C711EAAA5EBC019352B05E",
"Transcript":"support@sap.com : Hello Peter\n Peter.parker@test.com: Hello\n peter.parker@test.com : I need to book an appointment for fixing my washing machine\nsupport@sap.com :
Sure, will tomorrow 12.00 PM work for you? \n Peter.Parker@test.com: yes thanks bye\nsupport@sap.com : bye"
} - Transcript – Contains the plain text chat transcript.
See Also
- 3251501 - Customer Hub View does not open with new inbound phone call while using the Live Activity
- 2800665 - SAP Contact Center ECF chat integrated with C4C using the Live Activity RUI is not showing the chat transcript in the live activities
- 2803384 - UpdateActivity Event in CTI adapter is not updating the changes in the Activity
Keywords
Transcript, chat, update, activity , KBA , LOD-CRM-LA , Live Activity , Problem