SAP Knowledge Base Article - Public

3259486 - Cannot log onto SF - Incorrect primary assignment

Symptom

  • Re-hire not able to login.
  • Error message when trying to login:
    • Incorrect username or password
    • Invalid login. Please close your browser or relog in.
  • In Manage Login accounts - the affected user's primary assigned is an inactive profile. 
  • Inactive assignment assigned to user as primary user. 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Try to access SF with the affected user. 
  2. Examine the login failure occur.
  3. Log into SF with support user / unaffected user. 
  4. Go to Manage Login Accounts. 
  5. Search for the affected user who cannot access SF. 
  6. Examine how an inactive profile is assigned to the user as their primary assignment ID. 

Cause

  • Incorrect primary assignment.
  • No secondary assignment assigned to the user, so the initial assignment is taking precedent as the primary assignment ID. 

Resolution

In order to correct the primary assignment ID, please follow these steps: 

  1. Go to Check Tool
  2. On Application, choose User Management
  3. Click on 'Primary assignment should be correct for each person. (IncorrectPrimaryAssignmentCheckExecutor)
  4. Click on Quick Fix

See Also

Keywords

manage login account, linked account, user login information, Secondary assignment, Primary assignment, troubleshooting, login error, login permission, issue, Global assignment, Concurrent employment, Primary assignment login issue, INC4518812 , KBA , LOD-SF-PLT-MLA , Manage Login Accounts , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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