Symptom
- Users cannot log onto SF with their primary ID.
- In Manage Login accounts - the affected users primary assigned is an inactive profile.
- Inactive assignment assigned to user as primary user.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HXM Suite Core
Reproducing the Issue
- Try to access SF with the affected user's primary assignment ID.
- Examine the login failure occur.
- Log into SF with support user/unaffected user.
- Go to Manage Login Accounts.
- Search for an affected user who cannot access with their primary assignment ID.
- Examine how an inactive profile is assigned to the user as their primary assignment ID.
Cause
No secondary assignment assigned to the user, so the initial assignment is taking precedent as the primary assignment ID.
Resolution
Set a secondary assignment for the affected users allowing for the inactive profile to become the secondary and the desired assignment to become the primary to allow the user to login with this.
See Also
- 2859043 - Manage Login Accounts tool - SAP ONE Support Launchpad
- 3045327 - [1H 2021] Impact of Primary Assignment on User Login - Platform - SAP ONE Support Launchpad
- 2788892 - Unable to Purge User / Employment Because it is a Main Assignment - SAP ONE Support Launchpad
- 2410089 - RBP: How to check Login Permission? - SAP ONE Support Launchpad
Keywords
manage login account, linked account, user login information, Secondary assignment, Primary assignment, troubleshooting, login error, login permission, issue, Global assignment, Concurrent employment, Primary assignment login issue , KBA , LOD-SF-PLT-MLA , Manage Login Accounts , Problem