Symptom
In C4C, you have enabled the following options in the Company Settings:
- "Enable outbound calls in Microsoft Teams"
After you enabled this, you noticed that every time the agent selects a phone number, the call is routed to the MS Teams client and a new browser tab is opened.
So, each time the click to call option is invoked, the system generates a new popup which invokes MS Teams.
Environment
- SAP Cloud for Customer
Reproducing the Issue
- Go to C4C;
- Go to Company Settings;
- Select: "Enable outbound calls in Microsoft Teams"
You will notice that each time the click to call option is invoked, the system generates a new popup which invokes MS Teams.
Cause
If company settings for outbound call are enabled, then call via MS team will take priority.
This is the system expected behavior.
Resolution
Currently, this scenario is the current system behavior.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
MS Teams, Company Settings, Outbound Call, tab, new window. , KBA , AP-RC-MOB-UIF , Responsive UI , How To