Symptom
Whenever BRIM integration or Subscription Billing integration is enabled in CPQ, customer is unable to make any changes to the Quote Items table using the "Sections/ItemsTable" Responsive template.
Environment
SAP SALES CLOUD CPQ
Cause
- Both SB and BRIM integrations are supported only for Quote 2.0 engines.
- So when using a tenant on Quote 2.0, Sections/SubscriptionItemsTable template should be used.
- And when using a tenant on Quote 1.0, then Sections/ItemsTable template is used.
Resolution
- If customer is using Subscription Billing (SB) or BRIM integration then Cart Sections/SubscriptionItemsTable template should be used to make changes to the Quote Items table.
- Otherwise Cart Sections/ItemsTable template should be used.
See Also
How to customize templates: https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/0504fd066650400d899197a5ea2dd7e9.html?q=responsive%20templates
Quote 1.0 vs Quote 2.0 - Feature Differences: https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/71ab96157a8442e9ab20a7fdc1863ed9.html?q=quote%202.0
Keywords
Quote Items table Customization, BRIM, enabled, disabled, quote, cart, templates, Responsive templates, UI templates, Cart page, sections, Billing Revenue Innovation Management, custom, Sections/SubscriptionItemsTable. SubscriptionItemsTable, Sections/ItemsTable , Sections, Items table template, items sections, Subscription Billing, SB, integration, Quote , Quote Items, Items table, customization, customise, customize, customisation, ItemsTable, Quote 2.0, Quote 1.0 , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem