SAP Knowledge Base Article - Preview

3260660 - After successful system replication setup Secondary_Active_Status showing Connection timeout

Symptom

After successfully setting up System Replication the status shows active. All services in sync.

However from the HANA Studio its observed from System Replication status overview the column 'SECONDARY_ACTIVE_STATUS' shows 'CONNECTION TIMEOUT' as does systemReplicationStatus.py

  • Nameserver trace shows errors:

e sr_nameserver    DRClient.cpp(00924) : Could not reach any host of site '<site id>' to send request 'dr_getservers'. Hosts: (<hostname>:40002) Errors: 
nameserver communication error;internal error(5500)
...
e sr_nameserver    DRClient.cpp(01917) : resolveHost <hostname> not found in global.ini/[system_replication_hostname_resolution]

  • nameserver trace on secondary site shows entries of:

Successfully sending encrypted request '<request>' to <host> via clear-text port=<port> as fallback. This is for backward-compatibility during near-zero-downtime-upgrade and may have performance degradation. If you run into this warning while the peer is not during upgrade, please check if the secure port <source_port> is firewalled

  • nameserver trace on primary shows repeated entries of

 e sr_nameserver    DRClient.cpp(01052) : Could not reach any host of site '<site id>' to send request 'dr_getremotereplicationinfo'. Hosts: (<ip address of secondary>:<port>) Errors: 
nameserver communication error;connection refused(5500)

This scenario can occur when system replication was previously working with the correct status, but SAP HANA was recently upgraded to 2 SPS7 or enable_ssl=on was recently set and confirmed to have the same value on both sites.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."


Read more...

Environment

SAP HANA Platform edition 2.0

Product

SAP HANA, platform edition 2.0

Keywords

system replication, Connection timeout, SECONDARY_ACTIVE_STATUS, replication status,  , KBA , HAN-DB-HA , SAP HANA High Availability (System Replication, DR, etc.) , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.