Symptom
Recruiters are not getting synchronized between RCM and RMK. Export Automated Process Logs, in Command Center v2, shows one of the following message:
1.
<result>FAILED</result>
<result-msg>NullPointerException: while trying to invoke the method com.jobs2web.common.util.TokenRequest.toString() of a null object loaded from local variable 'tokenRequest'</result-msg>
2.
<result>error</result>
<result-msg>RestCallException: java.net.SocketTimeoutException: connect timed out: [datacenter].successfactors.com:443</result-msg>
3.
"Cannot invoke "com.jobs2web.common.util.TokenRequest.toString()" because "tokenRequest" is null"
Note: Access to Command Center is required to extract Automated Process Logs.
Environment
SAP SuccessFactors Recruiting Marketing
Cause
Scenario 1 & 2: A possible cause is the "Deployment Data Center" field is incorrectly configured in Career Site Builder.
Scenario 3: This happens because the Company Id or Deployment Data Center is configured incorrectly in Career Site Builder.
Resolution
Scenario 1 & 2: It is necessary to correct the Deployment Data Center selected under Career Site Builder > Settings > Site Configuration > Site Integrations.
Scenario 3: Please correct the Company Id or Deployment Data Center fields on Career Site Builder > Settings > Site Configuration > Site Integration tab.
After performing the above change, click on the Execute Now button.
Keywords
error message, recruiter sync, users, export automated process logs, rmk, timeout, deployment, data, center , KBA , LOD-SF-RMK-INT , Int with RCM, Data Mapping, AwLi, Multilocation posting , Problem