Symptom
You are facing a system crash when trying to do a manual clearing of some open item in a customer account.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Receivables work center.
- Go to Customer Accounts subview.
- Select All Customers.
- Search for account ID XYZ (XYZ represents the customer account).
- Click View.
- Select the Open Items.
- Click Clear Manually button.
- You will see the following error message:
An error occurred
Please try resuming your work. If you still face issues, report an incident.
Details
ClassName
sap.b.controller.event.PostRequest
MethodName
post
Response
500 SAP Internal Server Error
500 SAP Internal Server Error
Cause
One possible reason for the system is crashing because of the document selected (i.e. invoice) doesn't have tax lines maintained on its respective Tax sections:
- Select the Open item that you would like to clear, in this case for example could be a customer invoice.
- Click View All.
- Go to Items tab > Taxes sub tab > Tax Details section, leading to the failure of register entries.
There are no Tax lines in the Invoice, hence system failed to do the clearing.
Resolution
If the document is already posted you should re-create the documents with the tax line items information, even though all the amounts are zero, the tax line item should be present, otherwise the system will crash due to such inconsistency.
SAP is not able to correct them from the backend system since they have already been completed.
Keywords