Symptom
You have created a Document Numbering Formats for Customer Invoicing, the prefix is INV and the Start Document ID is set to for sample 001.
But when creating the first invoice, this rule is picked as INV correctly but the Start Document ID is not 001, it is 10000001.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration - Overview view.
- Search and open activity: Document Numbering Formats for Customer Invoicing.
- Select Document Numbering Formats for Other Countries/Regions.
- You can see the prefix INV, it is with Start Document ID 001.
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Search the invoice, the invocie with prefix INV is INV10000001 instead of INV001.
Cause
There are multiple changes were made to the numbering rule for Invoice with prefix INV.
Change1: The initial prefix was 'ABC' and start document id was '10000001', this created a new numbering rule Rule1 in backend.
Change2: The prefix was updated to 'INV' but start document id was still '10000001', since the prefix was updated, this again created another numbering rule Rule2 in backend.
Change3: The prefix remained 'INV' and the start document id was updated to '001', since in this case the prefix was same as before, so no new rule was created in backend.
Due to this, when the first customer invoice was created it picked Rule2 with prefix 'INV' and Start Document ID as '10000001'.
Resolution
If you want to update the Start Document ID for any given prefix, it is recommended to first delete the existing numbering rule and create a new one with the same prefix and the new Start Document ID.
Keywords
Document Numbering Formats for Customer Invoicing; Start Document ID , KBA , AP-CI-CI-GLO , Cross-Country Extensions , Problem