Symptom
- You are using SAP Cloud for Customer Live Activity features
- Your business requires to use Custom Live Activity Customer Search BAdI Exit, using custom fields
- Payload sent from your CTI partner to C4C for such inbound phone call is quite similar to:
- <payload>
<Type>CALL</Type>
<EventType>INBOUND</EventType>
<ACTION>NOTIFY</ACTION>
<NRIC><\NRIC>
<CustomField1>12345><\CustomField1>
<ANI>+34912345678<\ANI>
<ExternalReferenceID>JA42D48FEAD3EA22AA5EBC019352B05E</ExternalReferenceID>
<ExternalOriginalReferenceID>AB163EA718FC1FFABDD5608C895AEFCD</ExternalOriginalReferenceID>
</payload>
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Inbound phone call
Cause
Incorrect configuration
Resolution
- The correct parameters for customFields at payload must be Custom_1, Custom_2, Custom_3, Custom_4 and not CustomField1, CustomField2, CustomField3. CustomField4
-
Check Local Adapter Integration -> Chapter Enable Inbound Calls, where you can find all URL parameters required to enable inbound phone calls.
See Also
- 2835910 - How to pass additional custom parameters to search and identify customers in Live Activity
Keywords
custom additional field BADI exit enhancement payload LA Live Activity InputData.CustomField1 CustomField Inbound call , KBA , LOD-CRM-LA , Live Activity , Problem
Product
SAP Cloud for Customer core applications 2208