Symptom
When multiple signers are added to sign an Offer Letter in DocuSign, e.g. at least hiring manager and candidate. After creation, the offer is sent to be signed, the hiring manager receives the DocuSign e-mail notification with the button link to access the offer letter. When the hiring manager clicks in the link, user is redirected to SF Career login screen, instead of taking him directly to the offer letter.
Environment
- SAP SuccessFactors Recruiting Management
- DocuSign
Reproducing the Issue
- Offer a letter using Online Offer with Esignature
- Go to Actions > Edit Recipients
- Replace name and email of first signer writing over the data for the info of hiring manager
- Add Recipient and add the information regarding the candidate as second signer
- Send the offer letter
Cause
Recipients name and e-mail cannot be replaced or manually erased and written over with new information.
SuccessFactors originally configured the recipient in signing order 1 as the candidate that needs to sign in through the portal. Updating that user's name and e-mail address does not remove the requirement to login to the portal.
Resolution
Do not modify the candidate's name and e-mail, but add the hiring manager as a new signer. After that, assigns the candidate to signing order 2 and updates the hiring manager to signing order 1.
Keywords
DS, multiple signers, offer, letter, Esignature , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem