SAP Knowledge Base Article - Public

3264952 - [Onboarding] Unable to Fetch Form Data Error for USA I9 Compliance form after 2H 2022 Release

Symptom

External user getting an error "Unable to Fetch Form Data" after 2H 2022 Release for i9 compliance forms

Environment

SAP SuccessFactors Onboarding

Cause

  • [COE0021]Invalid property names: PerPhone/areaCode.
  • Area Code is a required field for the compliance form 
  • However, this field is not enabled in the phoneInformation Data Model
  • We updated the Form I-9 Section 1 verification step so that it now includes the complete phone number (including area code) collected in the personal data collection step. If the format is incorrect, we've added a validation message that prompts the new hires to enter their phone number in the correct format. Hence Area Code should be enabled.

Resolution

  • Go to Manage Business Configuration > phoneInfo
  • Enable > Area Code
  • Save
  • Once you have enabled, the compliance forms should be loading successfully.

See Also

Keywords

2H 2022, Unable to Fetch Form Data, i9 compliance, us compliance, 2211 , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding 2211