SAP Knowledge Base Article - Public

3264952 - Unable to Fetch Form Data Error for USA I9 Compliance form after 2H 2022 Release - Onboarding

Symptom

External user getting an error "Unable to Fetch Form Data" after 2H 2022 Release for i9 compliance forms

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login as the candidate
  2. Try to start the form
  3. The error message is shown

Cause

[COE0021]Invalid property names: PerPhone/areaCode.

Area Code is a required field for the compliance form 

However, this field is not enabled in the phoneInformation Data Model

We updated the Form I-9 Section 1 verification step so that it now includes the complete phone number (including area code) collected in the personal data collection step. If the format is incorrect, we've added a validation message that prompts the new hires to enter their phone number in the correct format. Hence Area Code should be enabled.

Resolution

To solve the issue: 

  1. Go to Manage Business Configuration > phoneInfo
  2. Enable > Area Code
  3. Save
  4. Once you have enabled, the compliance forms should be loading successfully.

If the issue persists, follow these steps:

  1. Go to "Manage Business Configuration > Phone Info
  2. Check if the fields mapped in the form is all enable
  3. Turn the fields mapped "enabled" (Make action > Take correction > change the "Enable" option to "Yes"

Note: Even if the workaround is implemented, the "Area Code" must be enabled if it's mapped in the compliance form.

See Also

U.S. Form I-9 and E-Verify Enhancements

Keywords

2H 2022, Unable, to, Fetch, Form, Data, i9, compliance, us, compliance, 2211, area, code, phoneinfo, phone , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding all versions